#5 キャプチャーの設定

カメラシステムのキャリブレーションが完了することで、Motiveはデータを収集する準備が整いました。しかしキャプチャを始める前に、キャプチャレコーディングを整理するためのセッションフォルダを用意し、リジッドボディやスケルトンなどのトラッキング可能なアセットを定義しましょう。

キャプチャーセッションを設定する

Motiveのレコーディングデータについて

各キャプチャはテイク(TAK)ファイルに保存され、関連するテイクファイルはSessionフォルダにまとめられます。最初に新しいSessionフォルダを作成してキャプチャを開始します。

ホストPCの任意のディレクトリに新しいフォルダを作成し、アイコンをクリックするかData Management Paneにドラッグ&ドロップすることでフォルダをData Management Paneにロードします。

セッションフォルダが読み込まれていない場合は、すべてのレコーディングデータがユーザードキュメントディレクトリ内のデフォルトフォルダ(Documents\OptiTrack\Default)に保存されます。新たに記録されたテイクはすべて、が表示された現在選択されているセッションフォルダ内に保存されます。

Motive Profiles

Motiveのソフトウェア構成は、Motive Profiles(*.motive拡張子)に保存されています。
アプリケーション関連の設定はすべてMotive Profilesに保存でき、これらのファイルをエクスポートおよびインポートすることで同じソフトウェア構成を簡単に管理できます。

Data Management paneにセッションフォルダが読み込まれます。
Data Management paneにセッションフォルダが読み込まれます。
Windowsファイルエクスプローラーのセッションフォルダの例
Windowsファイルエクスプローラーのセッションフォルダの例

Application Settingsペインについて

モーションキャプチャにおける再構成(Reconstruction)とは、撮影したカメラ映像から得られた2次元座標から3次元座標を導き出すことであり、この処理を行うコアエンジンが「Point Cloud Reconstruction Engine」です。
同期した複数の画像を撮影した場合、検出されたマーカーの反射の図心位置をフレームごとに三角測量し、キャリブレーションされたキャプチャボリューム内のそれぞれの3D座標を求めます。
Application Settingペインには再構成エンジンのすべての設定とフィルターオプションが含まれており、パラメータを変更して再構成の品質を最適化することができます。
Motiveの[View]タブまたはメインツールバーのアイコンをクリックしてアクセスできます。

デフォルトの設定を読み込むためには、[Edit]タブ→[Reset Application Settings]から設定をリセットしてください。

マーカーの配置

トラッキングしたい被写体に再帰性反射マーカーを配置します。マーカーがしっかりと取り付けられていることを再確認してください。
スケルトントラッキングの場合はBuilder Paneを開きスケルトン作成オプションに移動して、使用したいマーカーセットを選択します。スケルトンのアバターの図に従ってマーカーを配置します。モーションキャプチャスーツを使用している場合は、スーツができるだけしっかりとフィットしていることを確認してください。
Motiveではスーツに配置した関連するマーカー群から各ボディセグメントの位置を導き出します。
そのため、マーカーの位置がなるべくずれないようにすることが重要です。

クアッドコプターに配置されたマーカー
クアッドコプターに配置されたマーカー
Motiveで定義された対応するRigid Body
Motiveで定義された対応するRigid Body
測定対象に配置されたマーカー
測定対象に配置されたマーカー
Builder Paneに表示されるBaseline(41)スケルトンのマーカー配置
Builder Paneに表示されるBaseline(41)スケルトンのマーカー配置

リジッドボディの作成

リジッドボディとは対象のオブジェクトが変形不可能であるという前提のもと、そのオブジェクト上に3つ以上のマーカーを配置し、相互接続した集合体です。オブジェクトにはリジッドボディ用のマーカーがしっかりと固定され、各マーカーの位置関係に基づいてオブジェクトが識別され、またリジッドボディの重心位置と6DoFの回転値を取得できるようになります。

トラッキング可能なアセットを作成する場合、
[Layout]→[Create]メニューをクリックし、モデル作成用のレイアウトにアクセスします。

リジッドボディを定義するには、以下のようにしてください。

  1. Perspective Viewで3つ以上のマーカーを選択します。
  2. Createレイアウトの中からBuilderペインを確認し、その中の「Type」を「Rigid Body」にします。
  3. 「Name」にリジッドボディの名前を入力して、「Create」ボタンをクリックします。

また、上記の1の選択状態のまま右クリックして[Rigid Body]→[Create Rigid Body From Selected]を選択することでも、CTRL+Tキーを使用して作成することもできます(リジッドボディ名はデフォルトネームになります)

Builder Paneを利用したリジッドボディの作成
Builder Paneを利用したリジッドボディの作成

スケルトンの作成

Motiveでスケルトンアセットは人間の動きをトラッキングするために使用されます。これらのアセットは、人間の被写体、つまりアクターにアタッチされた特定のマーカーセットに自動的にラベルを付け、スケルトンモデルを作成します。

複数のリジッドボディ的なセグメント上のマーカーを正しく識別するため、スケルトンアセットでは追加の計算が必要となります。そのためMotiveはアクターの各部位(関節など)を特定する、定義済みのスケルトンマーカーセットテンプレートを使用します。

スケルトンを作成するにはまず、適切な位置にマーカーを付けたアクターにキャプチャボリューム内に入ってもらい下記のようにしてください。

  1. Builder Paneを開き、[Skeleton]→[Create]を選択します。
  2. マーカーセットセクションで、使用したいマーカーセットを選択すると、マーカーを装着する場所が示されたCGモデルが表示されます。
  3. アクターのマーカー位置がBuilder Paneのマーカー位置と一致していることを確認したら、キャリブレーションポーズを取るようにアクターに指示します。
    最も一般的なキャリブレーションポーズは、T-poseです。
    T-poseでは、背筋を伸ばし、頭は正面を向いた正しい立位姿勢が必要です。
  4. 次に、両方の腕を横に伸ばし「T」字型にします。T-poseの状態で、3Dビューの目的のスケルトン内のすべてのマーカーを選択し、Builder Paneの [Create]ボタンをクリックします。目的のアクターのみが表示されている場合、マーカーを選択する必要はありません。
Builder Paneを使用したSkeletonの作成

Propertiesについて

プロパティを構成することで、スケルトンアセットの表示設定やスケルトン作成時のポーズ設定を変更することができます。
新規に作成されたスケルトンの場合、デフォルトのスケルトン作成プロパティはSettings→Assetsでの構成に基づいて作成されます。既存の、または記録されたスケルトンアセットのプロパティは、Motiveでスケルトンが選択されている際に表示されるProperties Paneで設定することが可能です。
[Properties]→[Quality Visual]をオンにすることで、スケルトンのセグメントの色をエラーの有無に応じて変更することができます。

ROM(Range of Motion)について

Motive3.4.0以降のバージョンでは、ROM機能により、作成したスケルトンの関節の位置を微調整したり、ボーンの調整を行うことで実際のアクターの動きにより適合させることができるようになりました。

ROM機能を使用するにはBuilderペインでスケルトン作成時に「Create+Refine」ボタンをクリックしてください。また、作成済のスケルトンにROM機能を使用するには、「Modify」タブに移動し、作成されたスケルトンを選択してRefineメニューから「Start…」を選択します。

被験者をTポーズまたはAポーズのいずれかでボリューム(キャプチャ空間)の中央に立たせてください。
キャリブレーションに推奨されるポーズのリストを確認するには、ヘルプボタンをクリックしてください。

スケルトンは、選択されたビジュアルと共に3Dビューポートに表示されます。サンプルの収集が開始される際、各ボーンセグメントは濃い緑色となります。

Builderペインには、各ボーンセグメントの進捗状況が表示されます。
これにより最適なキャリブレーションを行うために、アクターが体のどの部分を動かす必要があるかがわかります。

ビルダーペインの「Coverage」バーで、どのセグメントが十分なサンプルを収集できたか、どのセグメントがさらに必要かが確認できます。
また、該当のボーンセグメントは3Dビューポートで明るい緑色に変わります。

「Start Calculation」ボタンは、サンプル収集プロセスの早い段階で表示されます。

すべてのボーンセグメントのCoverageが完了するまで待ってから計算を開始することを推奨します。しかし、100%のカバレッジ達成が難しい場合で、収集されたサンプルに納得がいけば、ボタンが表示された後であればいつでも「Start Calculation」ボタンをクリックできます。

マーカーセット

リジッドボディやスケルトン以外の任意のオブジェクトとしてラベル付けされた(Labeled)マーカー群のアセットを作成することができます。
また、後ほど紹介する方法によりTrained MarkerSet機能を利用する事も可能です。

例として、リジッドボディのように位置関係が安定しないような、柔軟さをもつオブジェクトに適切な数のマーカーを取り付けます。これはオブジェクトによって大きく異なりますが、少なくともアウトラインと内部の屈曲点をカバーする必要があります。例えば、マットの場合は、マットの縁に沿ってマーカーを配置するだけでなく、中央にも非対称パターンでマーカーを散りばめます。

マーカーセットを作成する方法は以下の通りです。

  1. Builderペインを開き、Typeより[MarkerSet]を選択します。
  2. Nameに設定したいマーカーセット名を入力します。
  3. Perspective Viewでマーカーセットにしたいマーカーを選択し、[Create from Selection]ボタンをクリックします。
    または、Markersにマーカー数を設定することで、その数に応じた空白のマーカーラベルをもったマーカーセットが作成されます。

Trained MarkerSet

Motive:Body以上のライセンスがある場合は、トレーニング機能を利用して作成されたマーカーセットにその可動範囲と3D空間上での動きを学習させることができます。

たとえばスケルトンマーカーを使用しない動物の関節の動きや、縄跳びなどの紐の動き、布の各場所の波打つ動きなどを系統だてて計測することが可能です。

トレーニング機能を行うには下記のようにしてください。

  1. マーカーセットをすべてトラッキングできている.takファイルを収録します。
    この.takファイルはただ静止したものではなく、ある程度マーカーが想定する動きが行われている必要があります。
  2. 1で収録した.takファイルをDataペインから再生します。
  3. Builderペイン上部のタブを「Modify」に変更します。
  4. Trainingセクションの「Train from Take」をクリックし、トレーニングが不要になった場合は「Clear」ボタンを使用して、アセットの既存のトレーニングを削除します。

オーディオの設定

オーディオ入力機器があれば、Motiveでモーションキャプチャーデータと同期した音声を収録することが可能です。録音した音声ファイルは、キャプチャしたTakeから再生したり、WAV形式の音声ファイルとしてエクスポートしたりすることができます。Motiveでオーディオ入力デバイス(マイク)を使用する前に、デバイスが正しく接続され、Windowsで設定されていることを確認してください。

オーディオ録音・再生の手順

  1. オーディオ入力デバイス、オーディオ出力デバイスの接続を確認し、Motiveを起動します。
  2. [Application Settings]→[Audio]を開き、[Enable Capture]の横のボックスにチェックを入れます。
  3. 使用するオーディオ入力デバイスを選択します。
  4. [Test]ボタンを押して入力デバイスが正しく機能していることを確認します。
  5. 使用するオーディオ出力デバイスを選択します。
  6. オーディオ入力デバイスのDevice Formatが再生デバイス(スピーカーやヘッドセット)
    で使用されるDevice Formatと一致していることを確認してください。
    ※この項目が一致していない場合、録音されたオーディオは再生されません。
  7. キャプチャを開始します。
  8. オーディオ録音を含むテイクを開き、再生します。

オーディオデバイスフォーマット

録音されたオーディオをMotiveで再生するためには、録音されたオーディオのフォーマットと出力機器で使用されている音声フォーマットが厳密に一致していなければなりません。オーディオの通信チャンネルや周波数が一致していない場合、録音された音声は再生されません。

記録されたオーディオフォーマットは、テイクをキャプチャする際に使用された記録装置のフォーマットによって決定されます。しかし、入力機器と出力機器の音声フォーマットが必ずしも一致しない場合があります。
その場合は、入力デバイスのプロパティを調整して一致させる必要があります。デバイスのオーディオフォーマットは、Windowsのサウンド設定で構成できます。
「サウンド」で録音デバイスを選択し、「プロパティ」をクリックすると、下の図のように「詳細設定」タブでデフォルトのフォーマットを変更することができます。

サウンドからマイクのプロパティにアクセスします。
サウンドからマイクのプロパティにアクセスします。
マイクデバイス形式を構成します。
マイクデバイス形式を構成します。

この記事は役に立ちましたか?

サポートコンテンツ

購入後のお問い合わせ(ユーザーサポート)

ご購入後の技術的なご質問やトラブルシューティングは、下記フォームよりお問い合わせください。

ご利用対象と回答目安について

  • 本窓口は「製品導入後30日以内のお客様」または「サポートプログラム加入中のお客様」専用のお問い合わせ窓口です。それ以外のお客様からの質問にはお答えしかねますのでご了承ください。
  • 基本的に3営業日以内にご返答させていただきますが、夏季休業・年末年始休業などの際にはご返答が遅れることがあります。

Catalog Download カタログダウンロード

各種製品カタログのダウンロードはこちら。

ダウンロード

ダウンロード

Contact お問い合わせ

不明点やお困りごとなど、
お気軽にお問い合わせください。

  • お見積り
  • ご質問
  • 実機デモンストレーション希望
  • 打ち合わせ希望
  • 購入・発注
お見積り・お問い合わせ

お見積り・お問い合わせ